Extended Maintenance on PayEngine - INC0868546

Incident Report for Nets PayEngine

Resolved

This incident has been resolved.
Posted Jan 13, 2026 - 09:01 CET

Identified

Our maintenance window has been extended, resulting in additional downtime. We appreciate your patience and will keep you updated as soon as services are restored.
Posted Jan 13, 2026 - 08:35 CET
This incident affected: PayEngine Checkout and PayEngine API.